summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gl.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 3a1e90f427..5801085c21 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -489,6 +489,10 @@ OpenGL graphics API.")
(mesa (assoc-ref inputs "mesa")))
(substitute* "src/gen_dispatch.py"
(("/usr/bin/env python") python))
+ ;; Add support for aarch64, see upstream:
+ ;; https://github.com/anholt/libepoxy/pull/114
+ (substitute* "test/dlwrap.c"
+ (("GLIBC_2.4") "GLIBC_2.17\", \"GLIBC_2.4"))
(substitute* (find-files "." "\\.[ch]$")
(("libGL.so.1") (string-append mesa "/lib/libGL.so.1"))
(("libEGL.so.1") (string-append mesa "/lib/libEGL.so.1")))