summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gtk.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index bfe13cfa85..95d005a6f6 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -395,12 +395,13 @@ is part of the GNOME accessibility project.")
;; Run test-suite under a dbus session.
(lambda _
(zero? (system* "dbus-launch" "make" "check")))))))
- (inputs `(("atk" ,atk)
- ("at-spi2-core" ,at-spi2-core)
- ("dbus" ,dbus)
- ("glib" ,glib)))
+ (propagated-inputs
+ `(("at-spi2-core" ,at-spi2-core))) ; required by atk-bridge-2.0.pc
+ (inputs
+ `(("atk" ,atk)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("dbus" ,dbus) ; for testing
+ ("pkg-config" ,pkg-config)))
(synopsis "Assistive Technology Service Provider Interface, ATK bindings")
(description
"The Assistive Technology Service Provider Interface