summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ruby.scm19
1 files changed, 16 insertions, 3 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index aa4cae6f97..4739579bfd 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5033,17 +5033,17 @@ in standard Ruby syntax.")
(home-page "https://github.com/ruby/rake")
(license license:expat)))
-(define-public ruby-childprocess
+(define-public ruby-childprocess-0.6
(package
(name "ruby-childprocess")
- (version "0.9.0")
+ (version "0.6.3")
(source
(origin
(method url-fetch)
(uri (rubygems-uri "childprocess" version))
(sha256
(base32
- "0a61922kmvcxyj5l70fycapr87gz1dzzlkfpq85rfqk5vdh3d28p"))))
+ "1p3f43scdzx9zxmy2kw5zsc3az6v46nq4brwcxmnscjy4w4racbv"))))
(build-system ruby-build-system)
(arguments
`(#:tests? #f))
@@ -5057,3 +5057,16 @@ in standard Ruby syntax.")
programs running in the background, in Ruby.")
(home-page "http://github.com/enkessler/childprocess")
(license license:expat)))
+
+(define-public ruby-childprocess
+ (package
+ (inherit ruby-childprocess-0.6)
+ (name "ruby-childprocess")
+ (version "0.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "childprocess" version))
+ (sha256
+ (base32
+ "0a61922kmvcxyj5l70fycapr87gz1dzzlkfpq85rfqk5vdh3d28p"))))))