summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/lisp.scm18
1 files changed, 8 insertions, 10 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 2e840a087f..6246840afa 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -91,13 +91,6 @@
#:phases (alist-cons-before
'configure 'pre-conf
(lambda _
- ;; Patch bug when building readline support. This bug was
- ;; also observed by Debian
- ;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=741819
- (substitute* "o/gcl_readline.d"
- (("rl_attempted_completion_function = \
-\\(CPPFunction \\*\\)rl_completion;")
- "rl_attempted_completion_function = rl_completion;"))
(substitute*
(append
'("pcl/impl/kcl/makefile.akcl"
@@ -107,16 +100,21 @@
"gcl-tk/makefile.prev"
"add-defs1")
(find-files "h" "\\.defs"))
- (("SHELL=/bin/(ba)?sh")
- (string-append "SHELL=" (which "bash")))))
+ (("SHELL=/bin/bash")
+ (string-append "SHELL=" (which "bash")))
+ (("SHELL=/bin/sh")
+ (string-append "SHELL=" (which "sh"))))
+ #t)
;; drop strip phase to make maxima build, see
;; https://www.ma.utexas.edu/pipermail/maxima/2008/009769.html
(alist-delete 'strip
%standard-phases))))
+ (inputs
+ `(("gmp" ,gmp)
+ ("readline" ,readline)))
(native-inputs
`(("gcc" ,gcc-4.9)
("m4" ,m4)
- ("readline" ,readline)
("texinfo" ,texinfo)
("texlive" ,texlive)))
(home-page "https://www.gnu.org/software/gcl/")