summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gtk.scm7
-rw-r--r--gnu/packages/xorg.scm16
2 files changed, 21 insertions, 2 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 92f399ecb6..057c808597 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -689,9 +689,12 @@ application suites.")
("pkg-config" ,pkg-config)
("gobject-introspection" ,gobject-introspection)
("python-wrapper" ,python-wrapper)
- ("xorg-server" ,xorg-server)))
+ ;; By using a special xorg-server for GTK+'s tests, we reduce the impact
+ ;; of updating xorg-server directly on the master branch.
+ ("xorg-server" ,xorg-server-1.19.2)))
(arguments
- `(;; 47 MiB goes to "out" (24 of which is locale data!), and 26 MiB goes
+ `(#:disallowed-references (,xorg-server-1.19.2)
+ ;; 47 MiB goes to "out" (24 of which is locale data!), and 26 MiB goes
;; to "doc".
#:configure-flags (list (string-append "--with-html-dir="
(assoc-ref %outputs "doc")
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 5c9300e209..bd8f38c398 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5111,6 +5111,22 @@ communicates with the user via graphical controls such as buttons and
draggable titlebars and borders.")
(license license:x11)))
+;;; This package is intended to be used when building GTK+.
+(define-public xorg-server-1.19.2
+ (package
+ (inherit xorg-server)
+ (name "xorg-server")
+ (version "1.19.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://xorg/individual/xserver/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1fw4b2lf75nsqkiyhn95b1c2if1l3cw5a188a1szx1d8l7sbk2jg"))))))
+
(define-public xorg-server-xwayland
(package
(inherit xorg-server)