summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/tor.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index f598672d91..50295da5dc 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -231,7 +231,9 @@ networks.")
;; After all the patching we run the tests after installing.
;; This is also a known issue:
;; https://github.com/micahflee/onionshare/issues/284
- (lambda _ (zero? (system* "nosetests" "test")))))))
+ (lambda _
+ (invoke "nosetests" "test")
+ #t)))))
(native-inputs
`(("python-nose" ,python-nose)))
(inputs