summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/cran.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8d1a78b2cb..43b738c377 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -13272,3 +13272,34 @@ intended to be useful for people dealing with web-related datasets, such as
server-side logs, although may be useful for other situations involving large
sets of URLs.")
(license license:expat)))
+
+(define-public r-ggforce
+ (package
+ (name "r-ggforce")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ggforce" version))
+ (sha256
+ (base32
+ "04rh9z58q288lbi933472lgl26wwbw58rfhpgfyijmw9ccz7i93m"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-gtable" ,r-gtable)
+ ("r-mass" ,r-mass)
+ ("r-polyclip" ,r-polyclip)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rcppeigen" ,r-rcppeigen)
+ ("r-rlang" ,r-rlang)
+ ("r-scales" ,r-scales)
+ ("r-tweenr" ,r-tweenr)))
+ (home-page "https://ggforce.data-imaginist.com")
+ (synopsis "Accelerating ggplot2")
+ (description
+ "The aim of the ggplot2 package is to aid in visual data investigations.
+This focus has led to a lack of facilities for composing specialized plots.
+Thi package aims to be a collection of mainly new statistics and geometries
+that fills this gap.")
+ (license license:expat)))