summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-web.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 1d99239dbb..5423aa917e 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2016, 2017 Danny Milosavljevic <dannym+a@scratchpost.org>
;;; Copyright © 2013, 2014, 2015, 2016 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2016, 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2016, 2017, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016, 2017, 2020 Julien Lepiller <julien@lepiller.eu>
@@ -92,7 +92,6 @@
(base32
"09pkw6f1790prnrq0k8cqgnf1qy57ll8lpmc6kld09q7zw4vi6i5"))
(patches (search-patches "python-aiohttp-3.6.2-no-warning-fail.patch"))))
-
(build-system python-build-system)
(arguments
'(#:phases
@@ -106,6 +105,17 @@
;; make sure the timestamp of this file is > 1990, because a few
;; tests like test_static_file_if_modified_since_past_date depend on it
(invoke "touch" "-d" "2020-01-01" "tests/data.unknown_mime_type")
+
+ ;; FIXME: These tests are failing due to deprecation warnings
+ ;; in Python 3.8. Remove this when updating to aiohttp >= 3.7.
+ ;; https://github.com/aio-libs/aiohttp/issues/4477
+ ;; https://github.com/aio-libs/aiohttp/issues/4525
+ (with-directory-excursion "tests"
+ (for-each delete-file '("test_client_session.py"
+ "test_multipart.py"
+ "test_web_middleware.py"
+ "test_web_protocol.py"
+ "test_web_urldispatcher.py")))
#t)))))
(propagated-inputs
`(("python-aiodns" ,python-aiodns)