summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2a83da6e9d..755fd59294 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9839,10 +9839,11 @@ concurrent.futures package from Python 3.2")
("python-mock" ,python-mock)
("python-tornado" ,python-tornado)))
(propagated-inputs
- `(;; extra packages for https security
+ `(;; These 5 inputs are used to build urrlib3[secure]
("python-certifi" ,python-certifi)
- ("python-ndg-httpsclient" ,python-ndg-httpsclient)
- ("python-pyasn1" ,python-pyasn1)
+ ("python-cryptography" ,python-cryptography) ;
+ ("python-idna" ,python-idna)
+ ("python-ipaddress" ,python-ipaddress)
("python-pyopenssl" ,python-pyopenssl)))
(home-page "https://urllib3.readthedocs.org/")
(synopsis "HTTP library with thread-safe connection pooling")