summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/image.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 3f758b779d..eef73d68ab 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -612,7 +612,16 @@ collection of tools for doing simple manipulations of TIFF images.")
(string-append " " (which "sh") " "))
(("which gnuplot")
"true"))
- #t)))))
+ #t))
+ (add-after 'install 'provide-absolute-giflib-reference
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (giflib (assoc-ref inputs "giflib")))
+ ;; Add an absolute reference to giflib to avoid propagation.
+ (with-directory-excursion (string-append out "/lib")
+ (substitute* '("liblept.la" "pkgconfig/lept.pc")
+ (("-lgif") (string-append "-L" giflib "/lib -lgif"))))
+ #t))))))
(home-page "http://www.leptonica.com/")
(synopsis "Library and tools for image processing and analysis")
(description