summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/graphics.scm17
-rw-r--r--gnu/packages/patches/openexr-missing-samples.patch23
3 files changed, 5 insertions, 36 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index d929ec0da8..1924ae9467 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1000,7 +1000,6 @@ dist_patch_DATA = \
%D%/packages/patches/ola-readdir-r.patch \
%D%/packages/patches/openbabel-fix-crash-on-nwchem-output.patch \
%D%/packages/patches/opencascade-oce-glibc-2.26.patch \
- %D%/packages/patches/openexr-missing-samples.patch \
%D%/packages/patches/openfoam-4.1-cleanup.patch \
%D%/packages/patches/openldap-CVE-2017-9287.patch \
%D%/packages/patches/openocd-nrf52.patch \
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index e5ec318e1b..9c2869c12b 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -320,29 +320,22 @@ graphics.")
(define-public openexr
(package
(name "openexr")
- (version "2.2.1")
+ (version "2.3.0")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://savannah/openexr/openexr-"
+ (uri (string-append "https://github.com/openexr/openexr/releases"
+ "/download/v" version "/openexr-"
version ".tar.gz"))
(sha256
(base32
- "1kdf2gqznsdinbd5vcmqnif442nyhdf9l7ckc51410qm2gv5m6lg"))
+ "19jywbs9qjvsbkvlvzayzi81s976k53wg53vw4xj66lcgylb6v7x"))
(modules '((guix build utils)))
(snippet
'(begin
(substitute* (find-files "." "tmpDir\\.h")
(("\"/var/tmp/\"")
"\"/tmp/\""))
-
- ;; Install 'ImfStdIO.h'. Reported at
- ;; <https://lists.nongnu.org/archive/html/openexr-devel/2016-06/msg00001.html>
- ;; and <https://github.com/openexr/openexr/pull/184>.
- (substitute* "IlmImf/Makefile.in"
- (("ImfIO\\.h")
- "ImfIO.h ImfStdIO.h"))
- #t))
- (patches (search-patches "openexr-missing-samples.patch"))))
+ #t))))
(build-system gnu-build-system)
(arguments
'(#:phases
diff --git a/gnu/packages/patches/openexr-missing-samples.patch b/gnu/packages/patches/openexr-missing-samples.patch
deleted file mode 100644
index 16cc9bb625..0000000000
--- a/gnu/packages/patches/openexr-missing-samples.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-This patch comments out tests that rely on files that are missing
-from the source tarball.
-
---- openexr-2.2.0/IlmImfTest/testSampleImages.cpp 2015-02-25 16:19:21.565105625 +0100
-+++ openexr-2.2.0/IlmImfTest/testSampleImages.cpp 2015-02-25 16:21:46.394128206 +0100
-@@ -162,16 +162,6 @@ testSampleImages (const std::string&)
- compareImages (ILM_IMF_TEST_IMAGEDIR "comp_b44.exr",
- ILM_IMF_TEST_IMAGEDIR "comp_b44_piz.exr");
-
-- compareImages (ILM_IMF_TEST_IMAGEDIR "comp_dwaa_v1.exr",
-- ILM_IMF_TEST_IMAGEDIR "comp_dwaa_piz.exr");
-- compareImages (ILM_IMF_TEST_IMAGEDIR "comp_dwaa_v2.exr",
-- ILM_IMF_TEST_IMAGEDIR "comp_dwaa_piz.exr");
--
-- compareImages (ILM_IMF_TEST_IMAGEDIR "comp_dwab_v1.exr",
-- ILM_IMF_TEST_IMAGEDIR "comp_dwab_piz.exr");
-- compareImages (ILM_IMF_TEST_IMAGEDIR "comp_dwab_v2.exr",
-- ILM_IMF_TEST_IMAGEDIR "comp_dwab_piz.exr");
--
-
- cout << "ok\n" << endl;
- }
-