summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bioinformatics.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4756444d95..947f99aa71 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8760,6 +8760,16 @@ of gene-level counts.")
"src/hdf5source/hdf5small.tgz" "-C" "src/" )
(substitute* "src/hdf5/configure"
(("/bin/mv") "mv"))
+ ;; Remove timestamp and host system information to make
+ ;; the build reproducible.
+ (substitute* "src/hdf5/src/libhdf5.settings.in"
+ (("Configured on: @CONFIG_DATE@")
+ "Configured on: Guix")
+ (("Uname information:.*")
+ "Uname information: Linux\n")
+ ;; Remove unnecessary store reference.
+ (("C Compiler:.*")
+ "C Compiler: GCC\n"))
#t)))))
(propagated-inputs
`(("r-zlibbioc" ,r-zlibbioc)))