summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-web.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 0dba566a77..76a2c57701 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -869,6 +869,37 @@ connection to each user.")
(license license:asl2.0)
(properties `((python2-variant . ,(delay python2-tornado))))))
+(define-public python-tornado-6
+ (package
+ (name "python-tornado")
+ (version "6.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "tornado" version))
+ (sha256
+ (base32
+ "1p5n7sw4580pkybywg93p8ddqdj9lhhy72rzswfa801vlidx9qhg"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "python" "-m" "tornado.test.runtests")
+ #t)))))
+ (native-inputs
+ `(("python-certifi" ,python-certifi)))
+ (home-page "https://www.tornadoweb.org/")
+ (synopsis "Python web framework and asynchronous networking library")
+ (description
+ "Tornado is a Python web framework and asynchronous networking library,
+originally developed at FriendFeed. By using non-blocking network I/O,
+Tornado can scale to tens of thousands of open connections, making it ideal
+for long polling, WebSockets, and other applications that require a long-lived
+connection to each user.")
+ (license license:asl2.0)))
+
(define-public python2-tornado
(let ((tornado (package-with-python2 (strip-python2-variant python-tornado))))
(package (inherit tornado)