summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5a7a21da5d..e2ef589acf 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6541,6 +6541,12 @@ complexity of Python source code.")
(modify-phases %standard-phases
(replace 'check
(lambda _
+ ;; Be compatible with Pytest 4:
+ ;; https://gitlab.com/pycqa/flake8-polyfill/merge_requests/7
+ (substitute* "setup.cfg"
+ (("\\[pytest\\]")
+ "[tool:pytest]"))
+
(setenv "PYTHONPATH"
(string-append (getcwd) "/build/lib:"
(getenv "PYTHONPATH")))