summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0a031baac2..062dfe1d2b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19694,3 +19694,25 @@ Open Sound Control 1.0} specification.")
(description "Python modules for text manipulation.")
(license #f)))
+(define-public python-pytest-testmon
+ (package
+ (name "python-pytest-testmon")
+ (version "1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-testmon" version))
+ (sha256
+ (base32
+ "1iasz23zrzjgbak8jiq12i4zmkk8f6dmcdhfxz8m2q03agcidc7x"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://testmon.org")
+ (synopsis
+ "Selects tests affected by changed files and methods")
+ (description
+ "Pytest module for selecting tests affected by changed files and
+methods.")
+ (license #f)))