summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2c354c8d71..153463f7bd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19778,3 +19778,26 @@ and watchdog.")
(description
"Use the Python requests library to talk HTTP via a UNIX domain socket.")
(license #f)))
+
+(define-public python-trustme
+ (package
+ (name "python-trustme")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trustme" version))
+ (sha256
+ (base32
+ "0v3vr5z6apnfmklf07m45kv5kaqvm6hxrkaqywch57bjd2siiywx"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-cryptography" ,python-cryptography)
+ ("python-idna" ,python-idna)))
+ (home-page
+ "https://github.com/python-trio/trustme")
+ (synopsis
+ "Fake certificate authority for unit tests")
+ (description
+ "Provides fake a fake TLS certificate authority for Python unit tests.")
+ (license #f)))