summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/finance.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index c31b87ec19..2553980aaa 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1594,3 +1594,42 @@ generate a variety of reports from them, and provides a web interface.")
(synopsis "Emacs mode for beancount")
(description
"Emacs-beancount is an Emacs mode for the Beancount accounting tool.")))
+
+(define-public fava
+ (package
+ (name "fava")
+ (version "1.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "fava" version))
+ (sha256
+ (base32
+ "181ypq2p7aaq2b76s55hxxbm1hykzf45mjjgm500h4dsaa167dqy"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("beancount" ,beancount)
+ ("python-babel" ,python-babel)
+ ("python-bottle" ,python-bottle)
+ ("python-cheroot" ,python-cheroot)
+ ("python-dateutil" ,python-dateutil)
+ ("python-click" ,python-click)
+ ("python-flask" ,python-flask)
+ ("python-flask-babel" ,python-flask-babel)
+ ("python-jinja2" ,python-jinja2)
+ ("python-lxml" ,python-lxml)
+ ("python-markdown2" ,python-markdown2)
+ ("python-magic" ,python-magic)
+ ("python-ply" ,python-ply)
+ ("python-simplejson" ,python-simplejson)
+ ("python-beautifulsoup4" ,python-beautifulsoup4)
+ ("python-werkzeug" ,python-werkzeug)))
+ (native-inputs
+ `(("python-setuptools-scm" ,python-setuptools-scm)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://beancount.github.io/fava/")
+ (synopsis
+ "Web interface for the accounting tool Beancount")
+ (description
+ "Fava is a web interface for the accounting tool Beancount.")
+ (license license:expat)))