summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/image-viewers.scm24
-rw-r--r--gnu/packages/lxde.scm4
2 files changed, 27 insertions, 1 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index ce75b1d835..a7e108a292 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2017 ng0 <contact.ng0@cryptolab.net>
+;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -122,6 +123,29 @@ image formats; tools for image comparison, sorting and managing photo
collection. Geeqie was initially based on GQview.")
(license license:gpl2+)))
+(define-public gpicview
+ (package
+ (name "gpicview")
+ (version "0.2.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/lxde/"
+ "GPicView%20%28image%20Viewer%29/0.2.x/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0hi9v0rdx47nys0wvm9xasdrafa34r5kq6crb074a0ipwmc60iiq"))))
+ (build-system gnu-build-system)
+ (inputs `(("gtk+" ,gtk+-2)
+ ("libjpeg" ,libjpeg)))
+ (native-inputs `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (synopsis "Simple and fast image viewer for X")
+ (description "gpicview is a lightweight GTK+ 2.x based image viewer.
+It is the default image viewer on LXDE desktop environment.")
+ (home-page "http://lxde.sourceforge.net/gpicview/")
+ (license license:gpl2+)))
+
(define-public sxiv
(package
(name "sxiv")
diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index 7abaab2c7e..1164ba8cbb 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -27,6 +27,7 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages image-viewers)
#:use-module (gnu packages linux)
#:use-module (gnu packages openbox)
#:use-module (gnu packages pkg-config)
@@ -435,9 +436,10 @@ in LXDE.")
(arguments '(#:builder (mkdir %output)))
(propagated-inputs
;; TODO:
- ;; lxshortcut, lxsession-edit, gpicview
+ ;; lxshortcut, lxsession-edit
;; lxappearance-obconf
`(("menu-cache" ,menu-cache)
+ ("gpicview" ,gpicview)
("leafpad" ,leafpad)
("lxappearance" ,lxappearance)
("lxde-icon-theme" ,lxde-icon-theme)