summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/lisp-xyz.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index cc9bda8ac6..b8efaf985f 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -2916,7 +2916,20 @@ is a library for creating graphical user interfaces.")
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "gobject/gobject.init.lisp"
(("libgobject" all) (string-append
- (assoc-ref inputs "glib") "/lib/" all))))))))))
+ (assoc-ref inputs "glib") "/lib/" all)))))
+ (add-after 'install 'link-source
+ ;; Since source is particularly heavy (16MiB+), let's reuse it
+ ;; across the different components of cl-ffi-gtk.
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((glib-source (string-append (assoc-ref inputs "cl-cffi-gtk-glib")
+ "/share/common-lisp/sbcl-source/"
+ "cl-cffi-gtk-glib"))
+ (out-source (string-append (assoc-ref outputs "out")
+ "/share/common-lisp/sbcl-source/"
+ "cl-cffi-gtk-gobject")))
+ (delete-file-recursively out-source)
+ (symlink glib-source out-source)
+ #t))))))))
(define-public sbcl-cl-cffi-gtk-gio
(package