summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/games.scm10
-rw-r--r--gnu/packages/serialization.scm4
2 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a072564d46..3d825cbe61 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1890,7 +1890,15 @@ match, cannon keep, and grave-itation pit.")
(modules '((guix build utils)))
(snippet
'(begin
- (delete-file-recursively "lib") #t))))
+ ;; Mimic upstream commit 706b6aad06, for compatibility with
+ ;; newer jsoncpp. Remove this for > 5.1.0.
+ (substitute* "cmake/Modules/FindJson.cmake"
+ (("features\\.h")
+ "allocator.h"))
+
+ ;; Delete bundled libraries.
+ (delete-file-recursively "lib")
+ #t))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 2bd1872bfd..00a8d27387 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -283,7 +283,7 @@ that implements both the msgpack and msgpack-rpc specifications.")
(define-public jsoncpp
(package
(name "jsoncpp")
- (version "1.9.1")
+ (version "1.9.2")
(home-page "https://github.com/open-source-parsers/jsoncpp")
(source (origin
(method git-fetch)
@@ -291,7 +291,7 @@ that implements both the msgpack and msgpack-rpc specifications.")
(file-name (git-file-name name version))
(sha256
(base32
- "00g356iv3kcp0gadj7gbyzf9jn9avvx9vxbxc7c2i5nnry8z72wj"))))
+ "037d1b1qdmn3rksmn1j71j26bv4hkjv7sn7da261k853xb5899sg"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags '("-DBUILD_SHARED_LIBS:BOOL=YES")))