diff options
-rw-r--r-- | ChangeLog | 5 | ||||
-rw-r--r-- | Makefile.am | 14 |
2 files changed, 17 insertions, 2 deletions
@@ -1 +1,4 @@ -Please see the Git commit log at <https://gitorious.org/guix>. +Normally a ChangeLog is generated at "make dist" time and available in +source tarballs. + +If not, see the Git commit log at <http://git.sv.gnu.org/cgit/guix.git/>. diff --git a/Makefile.am b/Makefile.am index 69b4af013a..538fad32a4 100644 --- a/Makefile.am +++ b/Makefile.am @@ -412,6 +412,18 @@ AM_DISTCHECK_CONFIGURE_FLAGS = \ --with-nix-prefix="$(NIX_PREFIX)" \ --enable-daemon -dist-hook: +dist-hook: sync-synopses gen-ChangeLog + +sync-synopses: -$(top_builddir)/pre-inst-env $(GUILE) \ $(top_srcdir)/build-aux/sync-synopses.scm + +gen-ChangeLog: + if test -d .git; then \ + $(top_srcdir)/build-aux/gitlog-to-changelog \ + > $(distdir)/cl-t; \ + rm -f $(distdir)/ChangeLog; \ + mv $(distdir)/cl-t $(distdir)/ChangeLog; \ + fi + +.PHONY: sync-synopses gen-ChangeLog |