summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/compression.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 67e3b880f6..e9ef302bcd 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -26,6 +26,7 @@
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2019 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
+;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -50,6 +51,7 @@
#:use-module (guix git-download)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system python)
#:use-module (guix build-system trivial)
#:use-module (gnu packages)
#:use-module (gnu packages assembly)
@@ -1851,6 +1853,17 @@ The specification of the Brotli Compressed Data Format is defined in RFC 7932.")
;; We used to provide an older version under the name "brotli".
(deprecated-package "brotli" google-brotli))
+(define-public python-google-brotli
+ (package
+ (inherit google-brotli)
+ (name "python-google-brotli")
+ (build-system python-build-system)
+ (arguments '())
+ (synopsis "Python interface to google-brotli")
+ (description "@code{python-google-brotli} provides a Python interface to
+@code{google-brotli}, an implementation of the Brotli lossless compression
+algorithm.")))
+
(define-public ucl
(package
(name "ucl")