summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/shells.scm18
1 files changed, 13 insertions, 5 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index c3647221aa..900c8ec686 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -336,11 +336,19 @@ history mechanism, job control and a C-like syntax.")
(("command -pv") "command -v")
(("command -p") "command ")
(("'command' -p") "'command' "))
- ;; Several of these tests fail spuriously in the Guix
- ;; build environment due to assumptions about PATH and
- ;; the location of the test files. It was easier to just
- ;; skip them than try to make them work.
- (delete-file "Test/A05execution.ztst")
+ ;; This file is ISO-8859-1 encoded.
+ (with-fluids ((%default-port-encoding #f))
+ (substitute* "Test/A05execution.ztst"
+ ;; Help it find `sh`
+ (("PATH=/bin:\\$\\{ZTST_testdir\\}/command.tmp/ tstcmd-slashless")
+ (string-append "PATH=/bin:"
+ (assoc-ref %build-inputs "bash") "/bin:"
+ "${ZTST_testdir}/command.tmp/ tstcmd-slashless"))
+ ;; Help it find `echo`
+ (("PATH=/bin:\\$\\{ZTST_testdir\\}/command.tmp tstcmd-arg")
+ (string-append "PATH=/bin:"
+ (assoc-ref %build-inputs "coreutils") "/bin:"
+ "PATH=/bin:${ZTST_testdir}/command.tmp tstcmd-arg"))))
#t)))))
(native-inputs `(("autoconf" ,autoconf)))
(inputs `(("ncurses" ,ncurses)