summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 840e0b763e..04b9fa2862 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2017 Raoul J.P. Bonnal <ilpuccio.febo@gmail.com>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017 humanitiesNerd <catonano@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1369,6 +1370,26 @@ contained in Appendix A of FIPS Publication 181, \"Standard for Automated
Password Generator\".")
(license (package-license perl))))
+(define-public perl-crypt-rc4
+ (package
+ (name "perl-crypt-rc4")
+ (version "2.02")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/S/SI/SIFUKURT/Crypt-RC4-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1sp099cws0q225h6j4y68hmfd1lnv5877gihjs40f8n2ddf45i2y"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Crypt-RC4")
+ (synopsis "Perl implementation of the RC4 encryption algorithm")
+ (description "A pure Perl implementation of the RC4 algorithm.")
+ (license (package-license perl))))
+
(define-public perl-cwd-guard
(package
(name "perl-cwd-guard")