aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/check.scm9
-rw-r--r--gnu/packages/compression.scm6
-rw-r--r--gnu/packages/freedesktop.scm14
-rw-r--r--gnu/packages/graphviz.scm70
-rw-r--r--gnu/packages/linux.scm4
5 files changed, 52 insertions, 51 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index db11d93bef..801bbf73e9 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -74,11 +74,10 @@ source code editors and IDEs.")
"057j82da9vv4li4z5ri3227ybd18nzyq81f6gsvhifs5z0vr3cpm"))))
(build-system gnu-build-system)
(arguments '(#:phases
- (alist-cons-before
- 'configure 'autoconf
- (lambda _
- (zero? (system* "autoreconf" "-vfi")))
- %standard-phases)))
+ (modify-phases %standard-phases
+ (add-before 'configure 'autoconf
+ (lambda _
+ (zero? (system* "autoreconf" "-vfi")))))))
(native-inputs
`(("automake" ,automake)
("autoconf" ,autoconf)
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 0a97ba7e60..a543d17776 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -456,21 +456,21 @@ some compression ratio).")
(define-public lzip
(package
(name "lzip")
- (version "1.18")
+ (version "1.19")
(source (origin
(method url-fetch)
(uri (string-append "mirror://savannah/lzip/lzip-"
version ".tar.gz"))
(sha256
(base32
- "1p8lvc22sv3damld9ng8y6i8z2dvvpsbi9v7yhr5bc2a20m8iya7"))))
+ "1abbch762gv8rjr579q3qyyk6c80plklbv2mw4x0vg71dgsw9bgz"))))
(build-system gnu-build-system)
(home-page "http://www.nongnu.org/lzip/lzip.html")
(synopsis "Lossless data compressor based on the LZMA algorithm")
(description
"Lzip is a lossless data compressor with a user interface similar to the
one of gzip or bzip2. Lzip decompresses almost as fast as gzip and compresses
-more than bzip2, which makes it well suited for software distribution and data
+more than bzip2, which makes it well-suited for software distribution and data
archiving. Lzip is a clean implementation of the LZMA algorithm.")
(license license:gpl3+)))
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 29f98a2356..93df44cac7 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -367,7 +367,19 @@ Python.")
(base32
"0lgywr1m0d79vr4s8aimj8a307nss29hhy68gjpqj7m667055c39"))))
(build-system gnu-build-system)
- (arguments `(#:parallel-tests? #f))
+ (arguments
+ `(#:parallel-tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ ;; Remove record shapes to workaround graphviz 2.40.1 problems.
+ ;; http://www.graphviz.org/content/i-havent-been-able-render-these-files-graphviz-226
+ ;; This will likely be fixed upstream in the next release.
+ ;; https://lists.freedesktop.org/archives/wayland-devel/2017-June/034218.html
+ (add-before 'build 'fix-graphviz
+ (lambda _
+ (substitute* "doc/doxygen/dot/x-architecture.gv"
+ (("Mrecord") "none"))
+ #t)))))
(native-inputs
`(("doxygen" ,doxygen)
("graphviz" ,graphviz)
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index d47d45e527..6724ba6d7d 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -44,51 +44,41 @@
(define-public graphviz
(package
(name "graphviz")
- (version "2.38.0")
+ (version "2.40.1")
(source (origin
- (method url-fetch)
- (uri (string-append
- "http://www.graphviz.org/pub/graphviz/ARCHIVE/graphviz-"
- version ".tar.gz"))
- (sha256
- (base32
- "17l5czpvv5ilmg17frg0w4qwf89jzh2aglm9fgx0l0aakn6j7al1"))))
+ (method url-fetch)
+ (uri (string-append
+ "http://www.graphviz.org/pub/graphviz/ARCHIVE/graphviz-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "08d4ygkxz2f553bxj6087da56a23kx1khv0j8ycxa102vvx1hlna"))))
(build-system gnu-build-system)
(arguments
;; FIXME: rtest/rtest.sh is a ksh script (!). Add ksh as an input.
'(#:tests? #f
-
- #:phases (alist-cons-before
- 'build 'pre-build
- (lambda _
- ;; Work around bogus makefile when using an external
- ;; libltdl. Failing to do so, one hits this error:
- ;; "No rule to make target `-lltdl', needed by `libgvc.la'."
- (substitute* "lib/gvc/Makefile"
- (("am__append_5 *=.*")
- "am_append_5 =\n")))
- (alist-cons-after
- 'install 'move-docs
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (doc (assoc-ref outputs "doc")))
- (mkdir-p (string-append doc "/share/graphviz"))
- (rename-file (string-append out "/share/graphviz/doc")
- (string-append doc "/share/graphviz/doc"))
- #t))
- (alist-cons-after
- 'move-docs 'move-guile-bindings
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (lib (string-append out "/lib"))
- (extdir (string-append lib
- "/guile/2.0/extensions")))
- (mkdir-p extdir)
- (rename-file (string-append
- lib "/graphviz/guile/libgv_guile.so")
- (string-append extdir
- "/libgv_guile.so"))))
- %standard-phases)))))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'move-docs
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (doc (assoc-ref outputs "doc")))
+ (mkdir-p (string-append doc "/share/graphviz"))
+ (rename-file (string-append out "/share/graphviz/doc")
+ (string-append doc "/share/graphviz/doc"))
+ #t)))
+ (add-after 'move-docs 'move-guile-bindings
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (lib (string-append out "/lib"))
+ (extdir (string-append lib
+ "/guile/2.0/extensions")))
+ (mkdir-p extdir)
+ (rename-file (string-append
+ lib "/graphviz/guile/libgv_guile.so")
+ (string-append extdir
+ "/libgv_guile.so"))
+ #t))))))
(inputs
`(("libXrender" ,libxrender)
("libX11" ,libx11)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d454b08029..304e0b7efa 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3011,7 +3011,7 @@ Bluetooth audio output devices like headphones or loudspeakers.")
(define-public bluez
(package
(name "bluez")
- (version "5.45")
+ (version "5.46")
(source (origin
(method url-fetch)
(uri (string-append
@@ -3019,7 +3019,7 @@ Bluetooth audio output devices like headphones or loudspeakers.")
version ".tar.xz"))
(sha256
(base32
- "1sb4aflgyrl7apricjipa8wx95qm69yja0lmn2f19g560c3v1b2c"))))
+ "0a4fj343bdqsfyv12hmj9nym0ilsf0bvm54a4apbiby16ww3vayx"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags