summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/libreoffice.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 23b1e2467c..5739757ce9 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -267,10 +267,11 @@ as Alfresco or Nuxeo.")
("gperf" ,gperf)
("perl" ,perl)
("pkg-config" ,pkg-config)))
- (inputs
- `(("boost" ,boost)
- ("librevenge" ,librevenge)
+ (propagated-inputs ; in Requires or Requires.private field of .pkg
+ `(("librevenge" ,librevenge)
("libxml2" ,libxml2)))
+ (inputs
+ `(("boost" ,boost)))
(arguments
;; avoid triggering configure errors by simple inclusion of boost headers
`(#:configure-flags '("--disable-werror")))