summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm25
-rw-r--r--gnu/packages/xml.scm26
2 files changed, 26 insertions, 25 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6d8e9caefc..1f8b936a12 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16621,31 +16621,6 @@ for manual interpretation.")
(description "Library for simple routing on OSM data")
(license license:gpl3+)))
-(define-public python-elementpath
- (package
- (name "python-elementpath")
- (version "1.2.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "elementpath" version))
- (sha256
- (base32
- "1syn2z543brab23dskh3fjd9pqvz6npqbcicrs2d88dbg26xl08p"))))
- (build-system python-build-system)
- (home-page
- "https://github.com/sissaschool/elementpath")
- (synopsis
- "XPath 1.0/2.0 parsers and selectors for ElementTree and lxml")
- (description
- "The proposal of this package is to provide XPath 1.0 and 2.0 selectors
-for Python's ElementTree XML data structures, both for the standard
-ElementTree library and for the @uref{http://lxml.de, lxml.etree} library.
-
-For lxml.etree this package can be useful for providing XPath 2.0 selectors,
-because lxml.etree already has it's own implementation of XPath 1.0.")
- (license license:expat)))
-
(define-public python-bibtexparser
(package
(name "python-bibtexparser")
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 5b9082cb26..83a2f1b713 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2050,6 +2051,31 @@ server using HTTP, and gets back the response as XML. This library provides a
modular implementation of XML-RPC for C and C++.")
(license (list license:psfl license:expat))))
+(define-public python-elementpath
+ (package
+ (name "python-elementpath")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "elementpath" version))
+ (sha256
+ (base32
+ "1syn2z543brab23dskh3fjd9pqvz6npqbcicrs2d88dbg26xl08p"))))
+ (build-system python-build-system)
+ (home-page
+ "https://github.com/sissaschool/elementpath")
+ (synopsis
+ "XPath 1.0/2.0 parsers and selectors for ElementTree and lxml")
+ (description
+ "The proposal of this package is to provide XPath 1.0 and 2.0 selectors
+for Python's ElementTree XML data structures, both for the standard
+ElementTree library and for the @uref{http://lxml.de, lxml.etree} library.
+
+For lxml.etree this package can be useful for providing XPath 2.0 selectors,
+because lxml.etree already has it's own implementation of XPath 1.0.")
+ (license license:expat)))
+
(define-public python-xmltodict
(package
(name "python-xmltodict")