summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 209564890e..f2e75d59a2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -981,8 +981,17 @@ to rebuild the original object tree.
Because only safe literals are encoded, it is safe to send serpent data to
other machines, such as over the network.")
+ (properties `((python2-variant . ,(delay python2-serpent))))
(license license:expat)))
+(define-public python2-serpent
+ (let ((base (package-with-python2 (strip-python2-variant python-serpent))))
+ (package
+ (inherit base)
+ (propagated-inputs
+ `(("python-enum34" ,python2-enum34)
+ ,@(package-propagated-inputs base))))))
+
(define-public python-setuptools
(package
(name "python-setuptools")