summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/libreoffice.scm14
-rw-r--r--gnu/packages/patches/libcmis-fix-test-onedrive.patch35
3 files changed, 7 insertions, 43 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 6e6f03a3ec..65be56ac47 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -675,7 +675,6 @@ dist_patch_DATA = \
%D%/packages/patches/liba52-use-mtune-not-mcpu.patch \
%D%/packages/patches/libbonobo-activation-test-race.patch \
%D%/packages/patches/libcanberra-sound-theme-freedesktop.patch \
- %D%/packages/patches/libcmis-fix-test-onedrive.patch \
%D%/packages/patches/libdrm-symbol-check.patch \
%D%/packages/patches/libevent-dns-tests.patch \
%D%/packages/patches/libevent-2.0-CVE-2016-10195.patch \
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index a962d9a301..52f4266920 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -243,15 +243,15 @@ working with graphics in the WPG (WordPerfect Graphics) format.")
(define-public libcmis
(package
(name "libcmis")
- (version "0.5.0")
+ (version "0.5.1")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://sourceforge/" name "/" name "-"
- version ".tar.gz"))
- (sha256 (base32
- "1dprvk4fibylv24l7gr49gfqbkfgmxynvgssvdcycgpf7n8h4zm8"))
- (patches (search-patches "libcmis-fix-test-onedrive.patch"))))
+ (uri (string-append "https://github.com/tdf/libcmis/releases/download/v"
+ version "/libcmis-" version ".tar.gz"))
+ (sha256
+ (base32
+ "03kvl8ywsv5qrxblf0m6955mmvl5q2zpb6vj51vs7ayvxhidzjva"))))
(build-system gnu-build-system)
(native-inputs
`(("cppunit" ,cppunit)
@@ -276,7 +276,7 @@ working with graphics in the WPG (WordPerfect Graphics) format.")
;; fails without the following flag.
(string-append "--with-boost="
(assoc-ref %build-inputs "boost")))))
- (home-page "https://sourceforge.net/projects/libcmis/")
+ (home-page "https://github.com/tdf/libcmis")
(synopsis "CMIS client library")
(description "LibCMIS is a C++ client library for the CMIS interface. It
allows C++ applications to connect to any ECM behaving as a CMIS server such
diff --git a/gnu/packages/patches/libcmis-fix-test-onedrive.patch b/gnu/packages/patches/libcmis-fix-test-onedrive.patch
deleted file mode 100644
index adf2e0b8e5..0000000000
--- a/gnu/packages/patches/libcmis-fix-test-onedrive.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Patch from resolution of http://sourceforge.net/p/libcmis/tickets/13/
-
-From 814c7845d53688b35a747cf193c2ff99e40a8652 Mon Sep 17 00:00:00 2001
-From: Jonathan Wakely <jwakely@redhat.com>
-Date: Wed, 2 Sep 2015 16:35:45 +0100
-Subject: [PATCH 5/5] Remove invalid comments from test JSON file.
-
----
- qa/libcmis/data/onedrive/search-result.json | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/qa/libcmis/data/onedrive/search-result.json b/qa/libcmis/data/onedrive/search-result.json
-index 61d250a..2482429 100644
---- a/qa/libcmis/data/onedrive/search-result.json
-+++ b/qa/libcmis/data/onedrive/search-result.json
-@@ -8,7 +8,7 @@
- },
- "name":"OneDriveFile",
- "description":"",
-- "parent_id":"folderA", // path: /A/Wrong File
-+ "parent_id":"folderA",
- "size":18047,
- "upload_location":"https://apis.live.net/v5.0/wrongFileId/content/",
- "comments_count":0,
-@@ -32,7 +32,7 @@
- },
- "name":"OneDriveFile",
- "description":"",
-- "parent_id":"folderC", // path: /A/B/C/Right File
-+ "parent_id":"folderC",
- "size":4,
- "upload_location":"https://apis.live.net/v5.0/rightFileId/content/",
- "comments_count":0,
---
-2.4.3 \ No newline at end of file