summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/linux.scm28
1 files changed, 24 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index aa6a021fef..60ffed27f1 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -872,14 +872,24 @@ It has been modified to remove all non-free binary blobs.")
linux-libre-source
'("armhf-linux")
#:defconfig "multi_v7_defconfig"
- #:extra-version "arm-generic"))
+ #:extra-version "arm-generic"
+ #:extra-options
+ (append
+ `(;; needed to fix the RTC on rockchip platforms
+ ("CONFIG_RTC_DRV_RK808" . #t))
+ %default-extra-linux-options)))
(define-public linux-libre-arm-generic-5.6
(make-linux-libre* linux-libre-5.6-version
linux-libre-5.6-source
'("armhf-linux")
#:defconfig "multi_v7_defconfig"
- #:extra-version "arm-generic"))
+ #:extra-version "arm-generic"
+ #:extra-options
+ (append
+ `(;; needed to fix the RTC on rockchip platforms
+ ("CONFIG_RTC_DRV_RK808" . #t))
+ %default-extra-linux-options)))
(define-public linux-libre-arm-veyron
(deprecated-package "linux-libre-arm-veyron" linux-libre-arm-generic))
@@ -924,14 +934,24 @@ It has been modified to remove all non-free binary blobs.")
linux-libre-source
'("aarch64-linux")
#:defconfig "defconfig"
- #:extra-version "arm64-generic"))
+ #:extra-version "arm64-generic"
+ #:extra-options
+ (append
+ `(;; needed to fix the RTC on rockchip platforms
+ ("CONFIG_RTC_DRV_RK808" . #t))
+ %default-extra-linux-options)))
(define-public linux-libre-arm64-generic-5.6
(make-linux-libre* linux-libre-5.6-version
linux-libre-5.6-source
'("aarch64-linux")
#:defconfig "defconfig"
- #:extra-version "arm64-generic"))
+ #:extra-version "arm64-generic"
+ #:extra-options
+ (append
+ `(;; needed to fix the RTC on rockchip platforms
+ ("CONFIG_RTC_DRV_RK808" . #t))
+ %default-extra-linux-options)))
(define-public linux-libre-riscv64-generic
(make-linux-libre* linux-libre-version