summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bioinformatics.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 7c58ab2455..1e04081ceb 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2063,7 +2063,21 @@ trees (phylogenies) and characters.")
(license license:bsd-3)))
(define-public python2-dendropy
- (package-with-python2 python-dendropy))
+ (let ((base (package-with-python2 python-dendropy)))
+ (package
+ (inherit base)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-failing-test
+ (lambda _
+ ;; This test fails when the full test suite is run, as documented
+ ;; at https://github.com/jeetsukumaran/DendroPy/issues/74
+ (substitute* "tests/test_dataio_nexml_reader_tree_list.py"
+ (("test_collection_comments_and_annotations")
+ "do_not_test_collection_comments_and_annotations"))
+ #t)))
+ ,@(package-arguments base))))))
(define-public python-py2bit
(package