summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 59d6824a8b..f0dc124681 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2019 Nicolò Balzarotti <anothersms@gmail.com>
;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
;;; Copyright © 2020 Todor Kondić <tk.code@protonmail.com>
+;;; Copyright © 2020 Danjela Lura <danielaluraa@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -100,6 +101,31 @@
the system clipboards.")
(license license:gpl3)))
+(define-public r-oenb
+ (package
+ (name "r-oenb")
+ (version "0.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "oenb" version))
+ (sha256
+ (base32
+ "1x1jlqp6r27c4gb7wafzpmh5rq6yq61a2d395r5lsmv2g5jb4biz"))))
+ (properties `((upstream-name . "oenb")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-dplyr" ,r-dplyr)
+ ("r-xml" ,r-xml)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/franzmohr/oenb")
+ (synopsis "Tools for the OeNB Data Web Service")
+ (description
+ "Tools to access data from the data web service of the
+@acronym{OeNB, Oesterreichische Nationalbank},
+@url{https://www.oenb.at/en/Statistics/User-Defined-Tables/webservice.html}.")
+ (license license:gpl2+)))
+
(define-public r-scales
(package
(name "r-scales")