summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ocaml.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index da98df546f..0f5fa0f09a 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -876,7 +876,7 @@ to the other.")
'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
- (system*
+ (invoke
"./configure"
"-bindir" (string-append out "/bin")
"-config" (string-append out "/etc/ocamfind.conf")
@@ -886,14 +886,15 @@ to the other.")
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
- (zero? (system* "make" "install"
- (string-append "OCAML_CORE_STDLIB="
- out "/lib/ocaml/site-lib"))))))
+ (invoke "make" "install"
+ (string-append "OCAML_CORE_STDLIB="
+ out "/lib/ocaml/site-lib")))))
(add-after 'install 'remove-camlp4
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(delete-file-recursively
- (string-append out "/lib/ocaml/site-lib/camlp4"))))))))
+ (string-append out "/lib/ocaml/site-lib/camlp4"))
+ #t))))))
(home-page "http://projects.camlcity.org/projects/findlib.html")
(synopsis "Management tool for OCaml libraries")
(description