summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/tls.scm12
1 files changed, 2 insertions, 10 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index f1dca66552..e99b7a83ba 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -260,7 +260,6 @@ required structures.")
(define-public openssl
(package
(name "openssl")
- (replacement openssl/fixed)
(version "1.0.2o")
(source (origin
(method url-fetch)
@@ -275,6 +274,8 @@ required structures.")
(base32
"0kcy13l701054nhpbd901mz32v1kn4g311z0nifd83xs2jbmqgzc"))
(patches (search-patches "openssl-runpath.patch"
+ "openssl-1.0.2-CVE-2018-0495.patch"
+ "openssl-1.0.2-CVE-2018-0732.patch"
"openssl-c-rehash-in.patch"))))
(build-system gnu-build-system)
(outputs '("out"
@@ -397,15 +398,6 @@ required structures.")
(license license:openssl)
(home-page "https://www.openssl.org/")))
-(define openssl/fixed
- (package
- (inherit openssl)
- (source (origin
- (inherit (package-source openssl))
- (patches (append (origin-patches (package-source openssl))
- (search-patches "openssl-1.0.2-CVE-2018-0495.patch"
- "openssl-1.0.2-CVE-2018-0732.patch")))))))
-
(define-public openssl-next
(package
(inherit openssl)