summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/music.scm52
1 files changed, 52 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 468be9937f..b1470d7820 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5213,3 +5213,55 @@ featureful and easy to use. It offers unlimited automation options, LV2
plugin support, JACK support and chord assistance.")
(home-page "https://www.zrythm.org")
(license license:agpl3+)))
+
+(define-public dragonfly-reverb
+ (package
+ (name "dragonfly-reverb")
+ (version "2.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/michaelwillis/dragonfly-reverb.git")
+ (commit version)
+ ;; Bundles a specific commit of the DISTRHO plugin framework.
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1qrbv4kk5v6ynx424h1i54qj0w8v6vpw81b759jawxvzzprpgq72"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no check target
+ #:make-flags (list "CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ;no configure target
+ (replace 'install ;no install target
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (lv2 (string-append out "/lib/lv2")))
+ ;; Install LV2.
+ (for-each
+ (lambda (file)
+ (copy-recursively file
+ (string-append lv2 "/" (basename file))))
+ (find-files "bin" "\\.lv2$" #:directories? #t))
+ ;; Install executables.
+ (install-file "bin/DragonflyRoomReverb" bin)
+ (install-file "bin/DragonflyHallReverb" bin)
+ #t))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("jack" ,jack-1)
+ ("libx11" ,libx11)
+ ("mesa" ,mesa)))
+ (home-page "https://michaelwillis.github.io/dragonfly-reverb/")
+ (synopsis "Concert hall reverb and room reverb effects")
+ (description
+ "Dragonfly Reverb is a bundle of two free audio effects: a concert
+hall reverb and a room reverb. Both are available as LV2 plugins as well
+as JACK standalone applications.")
+ (license license:gpl3+)))