summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gnupg.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index c5c3d5263f..9075978719 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -975,6 +975,16 @@ however, pgpdump produces more detailed and easier to understand output.")
(base32
"1cbpc45f8qbdkd62p12s3q2rdq6fa5xdzwmcwd3xrj55bzkspnwm"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-program
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (gnupg (assoc-ref inputs "gnupg")))
+ (wrap-program (string-append out "/bin/gpa")
+ `("PATH" ":" prefix (,(string-append gnupg "/bin"))))
+ #t))))))
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs