summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 86e87ae4dc..07199aa7ca 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3685,6 +3685,18 @@ writing C extensions for Python as easy as Python itself.")
(substitute-keyword-arguments (package-arguments base)
((#:phases phases)
`(modify-phases ,phases
+ ;; XXX: On i686-linux, running the parallel tests fails on many-core
+ ;; systems, see <https://github.com/cython/cython/issues/2807>.
+ ;; TODO: Move this logic to the regular check phase in a future
+ ;; rebuild cycle.
+ ,@(if (string-prefix? "i686" (%current-system))
+ '((replace 'check
+ (lambda _
+ (setenv "CFLAGS" "-O0")
+ (invoke "python" "runtests.py" "-vv"
+ "-j" (number->string (parallel-job-count))
+ "-x" "run.parallel"))))
+ '())
(add-before 'check 'adjust-test_embed
(lambda _
(substitute* "runtests.py"