summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/haskell-xyz.scm20
1 files changed, 0 insertions, 20 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 4b092299be..23a1ea5a36 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -6988,26 +6988,6 @@ that are much lighter weight than IO-threads.")
and other added capabilities layered on top of the @code{Par} monad.")
(license license:bsd-3)))
-(define-public ghc-monadplus
- (package
- (name "ghc-monadplus")
- (version "1.4.2")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://hackage.haskell.org/package/monadplus"
- "/monadplus-" version ".tar.gz"))
- (sha256
- (base32 "15b5320wdpmdp5slpphnc1x4rhjch3igw245dp2jxbqyvchdavin"))))
- (build-system haskell-build-system)
- (home-page "https://hackage.haskell.org/package/monadplus")
- (synopsis "Filtering and folding over arbitrary MonadPlus instances")
- (description
- "This package generalizes many common stream operations such as
-@code{filter}, @code{catMaybes} etc, enabling filtering and folding over
-arbitrary @code{MonadPlus} instances.")
- (license license:bsd-3)))
-
(define-public ghc-monadrandom
(package
(name "ghc-monadrandom")