summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/audio.scm4
-rw-r--r--gnu/packages/cdrom.scm2
-rw-r--r--gnu/packages/ftp.scm2
-rw-r--r--gnu/packages/graphics.scm4
-rw-r--r--gnu/packages/imagemagick.scm4
-rw-r--r--gnu/packages/maths.scm2
-rw-r--r--gnu/packages/networking.scm58
-rw-r--r--gnu/packages/scheme.scm2
-rw-r--r--gnu/packages/search.scm2
-rw-r--r--gnu/packages/video.scm43
-rw-r--r--gnu/packages/vim.scm2
11 files changed, 82 insertions, 43 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index b6e0a436c3..758c87cb2c 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -3734,7 +3734,7 @@ surround).")
(define-public libopenshot-audio
(package
(name "libopenshot-audio")
- (version "0.1.8")
+ (version "0.2.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3743,7 +3743,7 @@ surround).")
(file-name (git-file-name name version))
(sha256
(base32
- "1fvp6nmf30xzkmcznakh8dv5vn9d7nq051pqcqv638hsfppkmcrl"))))
+ "13if0m5mvlqly8gmbhschzb9papkgp3yqivklhb949dhy16m8zgf"))))
(build-system cmake-build-system)
(inputs
`(("alsa-lib" ,alsa-lib)
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index b6bdf33eef..d6127d11f9 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -213,7 +213,7 @@ files.")
`(#:tests? #f ; there is no check target
#:configure-flags ; Add $libdir to the RUNPATH of all the executables.
(list (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))))
- (home-page "http://www.xiph.org/paranoia/")
+ (home-page "https://www.xiph.org/paranoia/")
(synopsis "Audio CD reading utility")
(description "Cdparanoia retrieves audio tracks from CDDA capable CDROM
drives. The data can be saved to a file or directed to standard output
diff --git a/gnu/packages/ftp.scm b/gnu/packages/ftp.scm
index 58d817853b..273128f631 100644
--- a/gnu/packages/ftp.scm
+++ b/gnu/packages/ftp.scm
@@ -130,7 +130,7 @@ reliability in mind.")
(string-append "--prefix=" out))))))
#:tests? #f)) ;there are no tests
(inputs `(("ncurses" ,ncurses)))
- (home-page "http://www.ncftp.com/ncftp/")
+ (home-page "https://www.ncftp.com/ncftp/")
(synopsis "Command-line File Transfer Protocol (FTP) client")
(description
"NcFTP Client (or just NcFTP) is a set of command-line programs to access
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 985ebefa53..7414edb4fe 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -88,14 +88,14 @@
(define-public blender
(package
(name "blender")
- (version "2.82")
+ (version "2.82a")
(source (origin
(method url-fetch)
(uri (string-append "https://download.blender.org/source/"
"blender-" version ".tar.xz"))
(sha256
(base32
- "0rgw8nilvn6k6r7p28y2l1rwpami1cc8xz473jaahn7wa4ndyah0"))))
+ "18zbdgas6qf2kmvvlimxgnq7y9kj7hdxcgixrs6fj50x40q01q2d"))))
(build-system cmake-build-system)
(arguments
(let ((python-version (version-major+minor (package-version python))))
diff --git a/gnu/packages/imagemagick.scm b/gnu/packages/imagemagick.scm
index 064d1b6c40..3c1fe012d0 100644
--- a/gnu/packages/imagemagick.scm
+++ b/gnu/packages/imagemagick.scm
@@ -170,7 +170,7 @@ script.")
(define-public graphicsmagick
(package
(name "graphicsmagick")
- (version "1.3.34")
+ (version "1.3.35")
(source
(origin
(method url-fetch)
@@ -183,7 +183,7 @@ script.")
"/GraphicsMagick-" version ".tar.xz")))
(sha256
(base32
- "197pshms3m8mn2x1ryiag37ambm8qmb448spch66l3gdfd8rs06z"))))
+ "0l024l4hawm9s3jqrgi2j0lxgm61dqh8sgkj1017ma7y11hqv2hq"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index e694a5b187..499fdb06f7 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3463,7 +3463,7 @@ Fresnel integrals, and similar related functions as well.")
("lapack" ,lapack)
("metis" ,metis)))
(native-inputs
- `(("cmake" ,cmake)
+ `(("cmake" ,cmake-minimal)
("m4" ,m4)))
(home-page "http://faculty.cse.tamu.edu/davis/suitesparse.html")
(synopsis "Suite of sparse matrix software")
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index b7e79ce596..4fa5008149 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -23,7 +23,7 @@
;;; Copyright © 2018 Tonton <tonton@riseup.net>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Theodoros Foradis <theodoros@foradis.org>
-;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2018, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018, 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
@@ -342,33 +342,35 @@ between different versions of ØMQ.")
(license license:mpl2.0)))
(define-public cppzmq
- (let ((revision "0")
- (commit "d9f0f016c07046742738c65e1eb84722ae32d7d4"))
- (package
- (name "cppzmq")
- (version (string-append "4.2.2-" revision "."
- (string-take commit 7)))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/zeromq/cppzmq")
- (commit commit)))
- (sha256
- (base32
- "1gmqlm00y6xpa5m6d4ajq3ww63n2w7h4sy997wj81vcqmqx45b1f"))
- (file-name (string-append name "-" version "-checkout"))))
- (build-system cmake-build-system)
- (arguments '(#:tests? #f)) ; No tests.
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (inputs
- `(("zeromq" ,zeromq)))
- (home-page "http://zeromq.org")
- (synopsis "C++ bindings for the ØMQ messaging library")
- (description
- "This package provides header-only C++ bindings for ØMQ. The header
+ (package
+ (name "cppzmq")
+ (version "4.6.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zeromq/cppzmq")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "19acx2bzi4n6fdnfgkja1nds7m1bwg8lw5vfcijrx9fv75pa7m8h"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (arguments
+ '(;; FIXME: The test suite requires downloading Catch and custom
+ ;; CMake targets, and refuses to use the system version.
+ ;; See <https://github.com/zeromq/cppzmq/issues/334>.
+ #:tests? #f
+ #:configure-flags '("-DCPPZMQ_BUILD_TESTS=OFF")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("zeromq" ,zeromq)))
+ (home-page "http://zeromq.org")
+ (synopsis "C++ bindings for the ØMQ messaging library")
+ (description
+ "This package provides header-only C++ bindings for ØMQ. The header
files contain direct mappings of the abstractions provided by the ØMQ C API.")
- (license license:expat))))
+ (license license:expat)))
(define-public librdkafka
(package
@@ -550,7 +552,7 @@ test_parse_format_ipv(4(|_listen_all|_mapped_ipv6)|6)\\);")
("zlib" ,zlib)))
(native-inputs `(("check" ,check)
("pkg-config" ,pkg-config)))
- (home-page "http://code.kryo.se/iodine/")
+ (home-page "https://code.kryo.se/iodine/")
(synopsis "Tunnel IPv4 data through a DNS server")
(description "Iodine tunnels IPv4 data through a DNS server. This
can be useful in different situations where internet access is firewalled, but
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index e311de0638..d8a1a04ba4 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -801,7 +801,7 @@ utility functions for all standard Scheme implementations.")
(inputs `(("slib" ,slib)))
(native-inputs `(("unzip" ,unzip)
("texinfo" ,texinfo)))
- (home-page "http://people.csail.mit.edu/jaffer/SCM")
+ (home-page "https://people.csail.mit.edu/jaffer/SCM")
(synopsis "Scheme implementation conforming to R5RS and IEEE P1178")
(description "GNU SCM is an implementation of Scheme. This
implementation includes Hobbit, a Scheme-to-C compiler, which can
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index d1b67a3943..dcfd1ec1bd 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -249,7 +249,7 @@ for parsing HTML files.")
`(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out")
"/lib"))))
- (home-page "http://fallabs.com/hyperestraier")
+ (home-page "https://fallabs.com/hyperestraier")
(synopsis "Full-text search system")
(description "Hyper Estraier can be used to integrate full-text
search into applications, using either the provided command line and CGI
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 0e428f345d..c9d9cd5b91 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -25,7 +25,7 @@
;;; Copyright © 2018 Roel Janssen <roel@gnu.org>
;;; Copyright © 2018, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018, 2019 Pierre Neidhardt <mail@ambrevar.xyz>
-;;; Copyright © 2018, 2019 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2018, 2019, 2020 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
@@ -3493,7 +3493,7 @@ create smoother and stable videos.")
(define-public libopenshot
(package
(name "libopenshot")
- (version "0.2.3")
+ (version "0.2.5")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3502,7 +3502,7 @@ create smoother and stable videos.")
(file-name (git-file-name name version))
(sha256
(base32
- "0r1qmr8ar5n72603xkj9h065vbpznrqsq88kxxmn9n8djyyvk03k"))
+ "1mxjkgjmjzgf628y3rscc6rqf55hxgjpmvwxlncfk1216i5xskwp"))
(modules '((guix build utils)))
(snippet '(begin
;; Allow overriding of the python installation dir
@@ -3793,3 +3793,40 @@ Theora videos. Theorafile was written to be used for FNA's VideoPlayer.")
DVD using @command{libdvdcss}, but does @strong{not} demux, remux,
transcode or reformat the videos in any way, producing perfect backups.")
(license license:gpl3+)))
+
+(define-public svt-av1
+ (package
+ (name "svt-av1")
+ (version "0.8.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OpenVisualCloud/SVT-AV1.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "08sx9zhhks8wzq05f67jqmc1zqmmi7hqkgg2gyjpcsan5qc5476w"))))
+ (build-system cmake-build-system)
+ ;; SVT-AV1 only supports Intel-compatible CPUs.
+ (supported-systems '("x86_64-linux" "i686-linux"))
+ (arguments
+ ;; The test suite tries to download test data and git clone a 3rd-party
+ ;; fork of libaom. Skip it.
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-documentation
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref %outputs "out"))
+ (doc (string-append out "/share/doc/svt-av1-" ,version)))
+ (copy-recursively "../source/Docs" doc)
+ #t))))))
+ (native-inputs
+ `(("yasm" ,yasm)))
+ (synopsis "AV1 video codec")
+ (description "SVT-AV1 is an AV1 codec implementation. The encoder is a
+work-in-progress, aiming to support video-on-demand and live streaming
+applications. It only supports Intel-compatible CPUs (x86).")
+ (home-page "https://github.com/OpenVisualCloud/SVT-AV1")
+ (license license:bsd-2)))
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 5b03124e38..7bea7fa791 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -398,7 +398,7 @@ trouble using them, because you do not have to remember each snippet name.")
(synopsis "Scheme syntax for Vim")
(description
"@code{vim-scheme} provides Scheme support for Vim (R7RS and CHICKEN).")
- (home-page "http://foldling.org/git/vim-scheme.git/")
+ (home-page "https://foldling.org/git/vim-scheme.git/")
(license license:public-domain))))
(define-public vim-luna