summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/algebra.scm3
-rw-r--r--gnu/packages/gnome.scm4
-rw-r--r--gnu/packages/gtk.scm6
-rw-r--r--gnu/packages/patches/ruby-symlinkfix.patch53
-rw-r--r--gnu/packages/ruby.scm25
-rw-r--r--gnu/packages/swig.scm4
-rw-r--r--guix/build/cmake-build-system.scm1
8 files changed, 12 insertions, 85 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 49137277f1..a0269ab56d 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -841,7 +841,6 @@ dist_patch_DATA = \
%D%/packages/patches/ruby-concurrent-ignore-broken-test.patch \
%D%/packages/patches/ruby-puma-ignore-broken-test.patch \
%D%/packages/patches/ruby-rack-ignore-failing-test.patch \
- %D%/packages/patches/ruby-symlinkfix.patch \
%D%/packages/patches/ruby-tzinfo-data-ignore-broken-test.patch\
%D%/packages/patches/ruby-yard-fix-skip-of-markdown-tests.patch \
%D%/packages/patches/sed-hurd-path-max.patch \
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 76f385e340..cd212d4642 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -544,7 +544,8 @@ a C program.")
"1kwbx92ps0r7s2mqy7lxbxanslxdzj7dp7r7gmdkzv1j8yqf3kwf"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags '("--enable-shared" "--enable-openmp")
+ '(#:configure-flags
+ '("--enable-shared" "--enable-openmp" "--enable-threads")
#:phases (alist-cons-before
'build 'no-native
(lambda _
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 3aa0f567fd..8b94105ec2 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -682,14 +682,14 @@ update-desktop-database: updates the database containing a cache of MIME types
(define-public shared-mime-info
(package
(name "shared-mime-info")
- (version "1.6")
+ (version "1.7")
(source (origin
(method url-fetch)
(uri (string-append "https://freedesktop.org/~hadess/"
"shared-mime-info-" version ".tar.xz"))
(sha256
(base32
- "0k637g047gci8g69bg4g19akylpfraxm40hd30j3i4v7cidziy5j"))))
+ "0bjd2j1rqrj150mr04j7ib71lfdlgbf235fg8d70g8mszqf7ik7a"))))
(build-system gnu-build-system)
(arguments
;; The build system appears not to be parallel-safe.
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 17bd9c9b00..078df07235 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -165,7 +165,7 @@ affine transformation (scale, rotation, shear, etc.).")
(define-public harfbuzz
(package
(name "harfbuzz")
- (version "1.2.4")
+ (version "1.3.3")
(source (origin
(method url-fetch)
(uri (string-append "https://www.freedesktop.org/software/"
@@ -173,7 +173,7 @@ affine transformation (scale, rotation, shear, etc.).")
version ".tar.bz2"))
(sha256
(base32
- "14g4kpph8hgplkm954daxiymxx0vicfq7b7svvdsx54g5bqvv7a4"))))
+ "1jdkdjvci5d6r26vimsz24hz3xqqrk5xq40n693jn4m42mqrh816"))))
(build-system gnu-build-system)
(outputs '("out"
"bin")) ; 160K, only hb-view depend on cairo
@@ -198,7 +198,7 @@ affine transformation (scale, rotation, shear, etc.).")
"HarfBuzz is an OpenType text shaping engine.")
(license (license:x11-style "file://COPYING"
"See 'COPYING' in the distribution."))
- (home-page "http://www.freedesktop.org/wiki/Software/HarfBuzz/")))
+ (home-page "https://www.freedesktop.org/wiki/Software/HarfBuzz/")))
(define-public pango
(package
diff --git a/gnu/packages/patches/ruby-symlinkfix.patch b/gnu/packages/patches/ruby-symlinkfix.patch
deleted file mode 100644
index 16beecc97a..0000000000
--- a/gnu/packages/patches/ruby-symlinkfix.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-Fix symlinks to '..' to fix rubygems improperly expanding symlinked
-paths. Without this fix, some gems fail to install. This patch is applied in
-rubygems 2.5.2, but ruby version 2.3.1 bundles an older version of rubygems
-(2.5.1).
-
---- a/lib/rubygems/package.rb
-+++ b/lib/rubygems/package.rb
-@@ -383,7 +383,7 @@ def extract_tar_gz io, destination_dir, pattern = "*" # :nodoc:
- FileUtils.chmod entry.header.mode, destination
- end if entry.file?
-
-- File.symlink(install_location(entry.header.linkname, destination_dir), destination) if entry.symlink?
-+ File.symlink(entry.header.linkname, destination) if entry.symlink?
-
- verbose destination
- end
-diff --git a/test/rubygems/test_gem_package.rb b/test/rubygems/test_gem_package.rb
-index 7848bc2..f287bd3 100644
---- a/test/rubygems/test_gem_package.rb
-+++ b/test/rubygems/test_gem_package.rb
-@@ -428,19 +428,25 @@ def test_extract_tar_gz_absolute
- "#{@destination} is not allowed", e.message)
- end
-
-- def test_extract_tar_gz_symlink_absolute
-+ def test_extract_tar_gz_symlink_relative_path
-+ skip 'symlink not supported' if Gem.win_platform?
-+
- package = Gem::Package.new @gem
-
- tgz_io = util_tar_gz do |tar|
-- tar.add_symlink 'code.rb', '/absolute.rb', 0644
-+ tar.add_file 'relative.rb', 0644 do |io| io.write 'hi' end
-+ tar.mkdir 'lib', 0755
-+ tar.add_symlink 'lib/foo.rb', '../relative.rb', 0644
- end
-
-- e = assert_raises Gem::Package::PathError do
-- package.extract_tar_gz tgz_io, @destination
-- end
-+ package.extract_tar_gz tgz_io, @destination
-
-- assert_equal("installing into parent path /absolute.rb of " +
-- "#{@destination} is not allowed", e.message)
-+ extracted = File.join @destination, 'lib/foo.rb'
-+ assert_path_exists extracted
-+ assert_equal '../relative.rb',
-+ File.readlink(extracted)
-+ assert_equal 'hi',
-+ File.read(extracted)
- end
-
- def test_extract_tar_gz_directory
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index baae553992..6471f2ff45 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -47,8 +47,7 @@
(define-public ruby
(package
(name "ruby")
- (replacement ruby-2.3.3)
- (version "2.3.1")
+ (version "2.3.3")
(source
(origin
(method url-fetch)
@@ -57,9 +56,8 @@
"/ruby-" version ".tar.xz"))
(sha256
(base32
- "0f3395q7pd2hrl2gv26bib80038sjawxgmhl9zn22fjs9m9va9b7"))
+ "1p0rfk0blrbfjcnv0vb0ha4hxflgkfhv9zbzp4vvld2pi31ahkqs"))
(modules '((guix build utils)))
- (patches (search-patches "ruby-symlinkfix.patch"))
(snippet `(begin
;; Remove bundled libffi
(delete-file-recursively "ext/fiddle/libffi-3.2.1")
@@ -102,25 +100,6 @@ a focus on simplicity and productivity.")
(home-page "https://ruby-lang.org")
(license license:ruby)))
-(define ruby-2.3.3
- (package
- (inherit ruby)
- (version "2.3.3")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "http://cache.ruby-lang.org/pub/ruby/"
- (version-major+minor version)
- "/ruby-" version ".tar.xz"))
- (sha256
- (base32
- "1p0rfk0blrbfjcnv0vb0ha4hxflgkfhv9zbzp4vvld2pi31ahkqs"))
- (modules '((guix build utils)))
- (snippet `(begin
- ;; Remove bundled libffi
- (delete-file-recursively "ext/fiddle/libffi-3.2.1")
- #t))))))
-
(define-public ruby-2.2
(package (inherit ruby)
(version "2.2.6")
diff --git a/gnu/packages/swig.scm b/gnu/packages/swig.scm
index a615796745..acf0529377 100644
--- a/gnu/packages/swig.scm
+++ b/gnu/packages/swig.scm
@@ -31,7 +31,7 @@
(define-public swig
(package
(name "swig")
- (version "3.0.5")
+ (version "3.0.10")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/" name "/" name "/"
@@ -39,7 +39,7 @@
name "-" version ".tar.gz"))
(sha256
(base32
- "0g1a69vrqxgsnr1wkx851ljn73a2x3jqzxa66s2l3w0kyblbjk4z"))))
+ "0k7ljh07rla6223lhvljgg881b2qr7hmrfgic9a0j1pckpislf99"))))
(build-system gnu-build-system)
(native-inputs `(("boost" ,boost)
("pcre" ,pcre "bin"))) ;for 'pcre-config'
diff --git a/guix/build/cmake-build-system.scm b/guix/build/cmake-build-system.scm
index f57622e0f4..27f2b5c872 100644
--- a/guix/build/cmake-build-system.scm
+++ b/guix/build/cmake-build-system.scm
@@ -66,6 +66,7 @@
(define* (check #:key (tests? #t) (parallel-tests? #t) (test-target "test")
#:allow-other-keys)
(let ((gnu-check (assoc-ref gnu:%standard-phases 'check)))
+ (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
(gnu-check #:tests? tests? #:test-target test-target
#:parallel-tests? parallel-tests?)))