summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/tcl.scm14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index 18324ec94c..3ebdcbe5e2 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -95,14 +95,12 @@
("tcl" ,tcl)))
(arguments
'(#:configure-flags
- (list (string-append "--with-tcl="
- (assoc-ref %build-inputs "tcl")
- "/lib")
- (string-append "--with-tclinclude="
- (assoc-ref %build-inputs "tcl")
- "/include")
- (string-append "--exec-prefix="
- (assoc-ref %outputs "out")))
+ (let ((out (assoc-ref %outputs "out"))
+ (tcl (assoc-ref %build-inputs "tcl")))
+ (list (string-append "--with-tcl=" tcl "/lib")
+ (string-append "--with-tclinclude=" tcl "/include")
+ (string-append "--exec-prefix=" out)
+ (string-append "--mandir=" out "/share/man")))
#:phases (alist-cons-before
'configure 'set-path-to-stty