summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/commencement.scm2
-rw-r--r--tests/guix-build.sh4
2 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index b022a0d634..6a382c7517 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -2402,7 +2402,7 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
;; PKG-CONFIG.
;; TODO: Fix that on the next rebuild cycle.
(let ((pkg-config (package
- (inherit pkg-config)
+ (inherit %pkg-config) ;the native pkg-config
(inputs `(("guile" ,guile-final)
,@(%boot5-inputs)))
(arguments
diff --git a/tests/guix-build.sh b/tests/guix-build.sh
index 37666ffd01..52feda9d3a 100644
--- a/tests/guix-build.sh
+++ b/tests/guix-build.sh
@@ -226,6 +226,10 @@ rmdir "$result"
# Cross building.
guix build coreutils --target=mips64el-linux-gnu --dry-run --no-substitutes
+# Likewise, but with '-e' (see <https://bugs.gnu.org/38093>).
+guix build --target=arm-linux-gnueabihf --dry-run \
+ -e '(@ (gnu packages base) coreutils)'
+
# Replacements.
drv1=`guix build guix --with-input=guile@2.0=guile@2.2 -d`
drv2=`guix build guix -d`