summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/check.scm9
-rw-r--r--gnu/packages/cups.scm4
-rw-r--r--gnu/packages/gl.scm19
-rw-r--r--gnu/packages/glib.scm4
-rw-r--r--gnu/packages/imagemagick.scm4
-rw-r--r--gnu/packages/onc-rpc.scm16
-rw-r--r--gnu/packages/python-xyz.scm46
-rw-r--r--gnu/packages/sphinx.scm6
-rw-r--r--gnu/packages/textutils.scm32
-rw-r--r--gnu/packages/time.scm4
-rw-r--r--gnu/packages/vulkan.scm30
-rw-r--r--gnu/packages/xiph.scm4
-rw-r--r--gnu/packages/xorg.scm11
13 files changed, 126 insertions, 63 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 9bc5036cf6..36ecad03e2 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2061,18 +2061,17 @@ create data based on random numbers and yet remain repeatable.")
(define-public python-freezegun
(package
(name "python-freezegun")
- (version "0.3.11")
+ (version "0.3.12")
(source
(origin
(method url-fetch)
(uri (pypi-uri "freezegun" version))
(sha256
- (base32 "1nh0fzqjwg88n57k3qa8mxnmiwrr7lqyd5xvc96qn5g8zcxv8fg8"))))
+ (base32 "1rx57v8ryjncjimg8hys9kx1r3rknvwcl4y340g20jn0sf69qk9a"))))
(build-system python-build-system)
(native-inputs
`(("python-mock" ,python-mock)
- ("python-nose" ,python-nose)
- ("python-coverage" ,python-coverage)))
+ ("python-pytest" ,python-pytest)))
(propagated-inputs
`(("python-six" ,python-six)
("python-dateutil" ,python-dateutil)))
@@ -2083,7 +2082,7 @@ create data based on random numbers and yet remain repeatable.")
;; package does not include the Makefile.
(replace 'check
(lambda _
- (invoke "nosetests" "./tests/"))))))
+ (invoke "pytest" "-vv"))))))
(home-page "https://github.com/spulec/freezegun")
(synopsis "Test utility for mocking the datetime module")
(description
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index b48da35e8e..b87203cab6 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -57,7 +57,7 @@
(define-public cups-filters
(package
(name "cups-filters")
- (version "1.23.0")
+ (version "1.25.0")
(source(origin
(method url-fetch)
(uri
@@ -65,7 +65,7 @@
"cups-filters-" version ".tar.xz"))
(sha256
(base32
- "1lyzxf03kdfvkbb6p7hxlarbb35lq5bh094g49v3bz9z4z9065p2"))
+ "1laiscq8yvynw862calkgbz9irrdkmd5l821q6a6wik1ifd186c1"))
(modules '((guix build utils)))
(snippet
;; install backends, banners and filters to cups-filters output
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 99d2ec6cdb..cd82b17d15 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -46,6 +46,7 @@
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages tls)
#:use-module (gnu packages video)
+ #:use-module (gnu packages vulkan)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
@@ -223,7 +224,7 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa
(package
(name "mesa")
- (version "19.0.4")
+ (version "19.1.1")
(source
(origin
(method url-fetch)
@@ -235,7 +236,7 @@ also known as DXTn or DXTC) for Mesa.")
version "/mesa-" version ".tar.xz")))
(sha256
(base32
- "0iyffj3xd7f0vsayirswh6aia37ba26hkihpz273hxwd8hpz7y9r"))
+ "10amy5sdmpjbskr3xazgk0jyli8xpgi0y1nsmjr76hx8nhb4n4bj"))
(patches
(search-patches "mesa-skip-disk-cache-test.patch"))))
(build-system meson-build-system)
@@ -269,6 +270,13 @@ also known as DXTn or DXTC) for Mesa.")
`(("bison" ,bison)
("flex" ,flex)
("gettext" ,gettext-minimal)
+ ,@(match (%current-system)
+ ((or "x86_64-linux" "i686-linux")
+ `(("glslang" ,glslang)
+ ("vulkan-headers" ,vulkan-headers)
+ ("vulkan-loader" ,vulkan-loader)))
+ (_
+ `()))
("pkg-config" ,pkg-config)
("python" ,python)
("python-mako" ,python-mako)
@@ -305,6 +313,13 @@ also known as DXTn or DXTC) for Mesa.")
(_
'("-Dvulkan-drivers=auto")))
+ ;; Enable the Vulkan overlay layer on i686-linux and x86-64-linux.
+ ,@(match (%current-system)
+ ((or "x86_64-linux" "i686-linux")
+ '("-Dvulkan-overlay-layer=true"))
+ (_
+ '("")))
+
;; Also enable the tests.
"-Dbuild-tests=true"
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index d75b963794..ab9ed0b1bf 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -491,7 +491,7 @@ by GDBus included in Glib.")
(define libsigc++
(package
(name "libsigc++")
- (version "2.10.1")
+ (version "2.10.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/libsigc++/"
@@ -499,7 +499,7 @@ by GDBus included in Glib.")
name "-" version ".tar.xz"))
(sha256
(base32
- "00v08km4wwzbh6vjxb21388wb9dm6g2xh14rgwabnv4c2wk5z8n9"))))
+ "163s14d1rqp82gc1vsm3q0wzsbdicb9q6307kz0zk5lm6x9h5jmi"))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)
("m4" ,m4)))
diff --git a/gnu/packages/imagemagick.scm b/gnu/packages/imagemagick.scm
index 16f9a6e4bd..dba193d8e5 100644
--- a/gnu/packages/imagemagick.scm
+++ b/gnu/packages/imagemagick.scm
@@ -48,14 +48,14 @@
;; The 7 release series has an incompatible API, while the 6 series is still
;; maintained. Don't update to 7 until we've made sure that the ImageMagick
;; users are ready for the 7-series API.
- (version "6.9.10-46")
+ (version "6.9.10-49")
(source (origin
(method url-fetch)
(uri (string-append "mirror://imagemagick/ImageMagick-"
version ".tar.xz"))
(sha256
(base32
- "1qx3x48q1dy39g1bb8mnyaq9jwy1smf0x6zfly4r0mj3m01i2dyb"))))
+ "1w4vsppyn1h58x3z4hgly5qxp16q66l18y9rwavrravw0kiq64fs"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--with-frozenpaths" "--without-gcc-arch")
diff --git a/gnu/packages/onc-rpc.scm b/gnu/packages/onc-rpc.scm
index 64887212d3..8f66b07527 100644
--- a/gnu/packages/onc-rpc.scm
+++ b/gnu/packages/onc-rpc.scm
@@ -23,6 +23,7 @@
#:use-module (guix licenses)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages gettext)
@@ -33,7 +34,7 @@
(define-public libtirpc
(package
(name "libtirpc")
- (version "1.0.3")
+ (version "1.1.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/libtirpc/libtirpc/"
@@ -41,7 +42,7 @@
version ".tar.bz2"))
(sha256
(base32
- "0ppxl3k3nsz0qdakq844i2kj4fvh9h937lhx26bgmpmxq67sghw6"))))
+ "07anqypf7c719x9y683qz65cxllmzlgmlab2hlahrqcj4bq2k99c"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -105,13 +106,14 @@ universal addresses.")
(name "libnsl")
(version "1.2.0")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/thkukuk/libnsl/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/thkukuk/libnsl.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1y6kmxmv1difzvdhx7grqzw0j2v2b74mg4kjb803m8jcgkqqx8m5"))))
+ "1chzqhcgh0yia9js8mh92cmhyka7rh32ql6b3mgdk26n94dqzs8b"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 181899da36..4ba40e95b0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -314,14 +314,14 @@ by @code{binstar}, @code{binstar-build} and @code{chalmers}.")
(define-public python-babel
(package
(name "python-babel")
- (version "2.6.0")
+ (version "2.7.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Babel" version))
(sha256
(base32
- "08rxmbx2s4irp0w0gmn498vns5xy0fagm0fg33xa772jiks51flc"))))
+ "0a7wawx8vsg7igvz6p3x909fskhg4b2y1910xk4f4c8y22p3aqg8"))))
(build-system python-build-system)
(native-inputs
`(("python-freezegun" ,python-freezegun)
@@ -346,6 +346,18 @@ etc. ")
(define-public python2-babel
(package-with-python2 python-babel))
+;; Sphinx < 2.0 requires this version. Remove once no longer needed.
+(define-public python2-babel-2.6
+ (package
+ (inherit python2-babel)
+ (version "2.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "Babel" version))
+ (sha256
+ (base32
+ "08rxmbx2s4irp0w0gmn498vns5xy0fagm0fg33xa772jiks51flc"))))))
+
(define-public python2-backport-ssl-match-hostname
(package
(name "python2-backport-ssl-match-hostname")
@@ -2327,15 +2339,33 @@ e.g. filters, callbacks and errbacks can all be promises.")
(define-public python-markupsafe
(package
(name "python-markupsafe")
- (version "1.0")
+ (version "1.1.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "MarkupSafe" version))
(sha256
(base32
- "0rdn1s8x9ni7ss8rfiacj7x1085lx8mh2zdwqslnw8xc3l4nkgm6"))))
+ "0sqipg4fk7xbixqd8kq6rlkxj664d157bdwbh93farcphf92x1r9"))))
(build-system python-build-system)
+ (arguments
+ `(#:modules ((ice-9 ftw)
+ (srfi srfi-1)
+ (srfi srfi-26)
+ (guix build utils)
+ (guix build python-build-system))
+ #:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (let ((cwd (getcwd))
+ (libdir (find (cut string-prefix? "lib." <>)
+ (scandir "build"))))
+ (setenv "PYTHONPATH"
+ (string-append cwd "/build/" libdir ":"
+ (getenv "PYTHONPATH")))
+ (invoke "pytest" "-vv")))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
(home-page "https://github.com/mitsuhiko/markupsafe")
(synopsis "XML/HTML/XHTML markup safe string implementation for Python")
(description
@@ -2513,14 +2543,14 @@ reStructuredText.")
(define-public python-pygments
(package
(name "python-pygments")
- (version "2.4.0")
+ (version "2.4.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Pygments" version))
(sha256
(base32
- "1xb5n3hvhk63kxypc03k7kfry20pny6gygi4bsl9kw1rnzzsdjri"))))
+ "15v2sqm5g12bqa0c7wikfh9ck2nl97ayizy1hpqhmws5gqalq748"))))
(build-system python-build-system)
(arguments
;; FIXME: Tests require sphinx, which depends on this.
@@ -8641,14 +8671,14 @@ python-xdo for newer bindings.)")
(define-public python-mako
(package
(name "python-mako")
- (version "1.0.10")
+ (version "1.0.12")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Mako" version))
(sha256
(base32
- "0r9rysn19fmrxnzfcn7sg20kjhcrx9qri0my9n5vdzp1g2g92rbi"))))
+ "0qj16ai937wrbpv1a9g395gybb9s06rmdj3arbp8fpl37bg6byhc"))))
(build-system python-build-system)
(propagated-inputs
`(("python-markupsafe" ,python-markupsafe)))
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 0a7fc9606a..5ec769388a 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -45,14 +45,14 @@
(define-public python-sphinx
(package
(name "python-sphinx")
- (version "2.0.1")
+ (version "2.1.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Sphinx" version))
(sha256
(base32
- "0js0rnbzm0nsb4gm2v4z79wlbmr05awqzic57kfl8ydkdxj80cj2"))))
+ "09y4mjmbxz94pmfr2lzf1hkx2xk0khcpb8xsqfmir4l7dds9x9zr"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -132,7 +132,7 @@ sources.")
("python2-imagesize" ,python2-imagesize)
("python2-sphinx-alabaster-theme"
,python2-sphinx-alabaster-theme)
- ("python2-babel" ,python2-babel)
+ ("python2-babel" ,python2-babel-2.6)
("python2-snowballstemmer" ,python2-snowballstemmer)
("python2-docutils" ,python2-docutils)
("python2-jinja2" ,python2-jinja2)
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 79835e8578..d1dc14e6d7 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -140,32 +140,35 @@ libenca and several charset conversion libraries and tools.")
(define-public utf8proc
(package
(name "utf8proc")
- (version "2.1.1")
+ (version "2.4.0")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/JuliaLang/utf8proc/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaStrings/utf8proc")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1cnpigrazhslw65s4j1a56j7p6d7d61wsxxjf1218i9mkwv2yw17"))))
+ (base32 "1i42hqwc8znqii9brangwkxk5cyc2lk95ip405fg88zr7z2ncr34"))))
(build-system gnu-build-system)
- (inputs ; test data that is otherwise downloaded with curl
+ (native-inputs ;test data that is otherwise downloaded with curl
`(("NormalizationTest.txt"
,(origin
(method url-fetch)
- (uri (string-append "http://www.unicode.org/Public/9.0.0/ucd/"
+ (uri (string-append "https://www.unicode.org/Public/12.1.0/ucd/"
"NormalizationTest.txt"))
(sha256
- (base32 "1fxrz0bilsbwl685336aqi88k62i6nqhm62rvy4zhg3bcm4dhj1d"))))
+ (base32 "0hb97k9xv1lr847hwz0719ksqy39s47xw6k01dgs1368jdibvawc"))))
("GraphemeBreakTest.txt"
,(origin
(method url-fetch)
- (uri (string-append "http://www.unicode.org/Public/9.0.0/ucd/"
+ (uri (string-append "https://www.unicode.org/Public/12.1.0/ucd/"
"auxiliary/GraphemeBreakTest.txt"))
(sha256
- (base32 "0qbhyhmf0778lc2hcwlpizrvmdxwpk959v2q2wb8abv09ba7wvn7"))))))
+ (base32 "0qc90ppmrwfn3y9cdn8jcjrn7qpdf0fhxkwh945yp4rvh37mbgcm"))))
+
+ ;; For tests.
+ ("perl" ,perl)))
(arguments
'(#:make-flags (list "CC=gcc"
(string-append "prefix=" (assoc-ref %outputs "out")))
@@ -180,8 +183,9 @@ libenca and several charset conversion libraries and tools.")
'("NormalizationTest.txt" "GraphemeBreakTest.txt"))
(substitute* "data/GraphemeBreakTest.txt"
(("÷") "/")
- (("×") "+")))))))
- (home-page "https://julialang.org/utf8proc/")
+ (("×") "+"))
+ #t)))))
+ (home-page "https://juliastrings.github.io/utf8proc/")
(synopsis "C library for processing UTF-8 Unicode data")
(description "utf8proc is a small C library that provides Unicode
normalization, case-folding, and other operations for data in the UTF-8
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 747e4cf080..9bbfe07803 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -92,14 +92,14 @@ to a file.")
(define-public python-pytz
(package
(name "python-pytz")
- (version "2018.5")
+ (version "2019.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytz" version ".tar.gz"))
(sha256
(base32
- "0xzj5gkpdn2da8m6j47chlp6zrzcypv9m0fjv4236q3jw4fyzfgz"))))
+ "0hg1r2c41gnmljdsdmdgy6kb1zkfmxsf49imd96g8znp4cyxsiyp"))))
(build-system python-build-system)
(home-page "http://pythonhosted.org/pytz")
(synopsis "Python timezone library")
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index 6b151f0a31..9fb780de77 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -159,7 +159,7 @@ interpretation of the specifications for these languages.")
(define-public vulkan-headers
(package
(name "vulkan-headers")
- (version "1.1.107")
+ (version "1.1.112")
(source
(origin
(method git-fetch)
@@ -169,7 +169,7 @@ interpretation of the specifications for these languages.")
(file-name (git-file-name name version))
(sha256
(base32
- "0kyf83n6fghqmjj5jbwhy08yq5sl598qnmw3kbavrnw9avqqm0c4"))))
+ "0iia2wlq38hvxwip6r3k5946ylrlk42fw50mhf0pdjxjh02p8zn5"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f)) ; No tests.
@@ -193,7 +193,7 @@ interpretation of the specifications for these languages.")
(file-name (git-file-name name version))
(sha256
(base32
- "1p64k9x5r7nsrs0cn6d61687xbajqvsm78xk6j85w9wfin5dxs30"))))
+ "1819bgmpjlikcc25bkmwwb7mp1rlyrq2v74wybg1g40ix70v0m0d"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ;FIXME: 23/39 tests fail. Try "tests/run_all_tests.sh".
@@ -203,6 +203,28 @@ interpretation of the specifications for these languages.")
(lambda* (#:key inputs #:allow-other-keys)
;; Remove lines trying to build in a git commit id.
(substitute* "CMakeLists.txt" ((".*spirv_tools_commit_id.h.*") ""))
+ #t))
+ ;; Make sure that the files needed for Mesa's Vulkan overlay are availabe.
+ (add-after 'unpack 'copy-headers1
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "tests/layers/vk_layer_data.h"
+ (string-append (assoc-ref %outputs "out")
+ "/include/vulkan"))
+ (install-file "tests/layers/vk_layer_extension_utils.h"
+ (string-append (assoc-ref %outputs "out")
+ "/include/vulkan"))
+ (install-file "loader/vk_loader_platform.h"
+ (string-append (assoc-ref %outputs "out")
+ "/include/vulkan"))
+ #t))
+ (add-after 'build 'copy-headers2
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "vk_layer_dispatch_table.h"
+ (string-append (assoc-ref %outputs "out")
+ "/include/vulkan"))
+ (install-file "vk_dispatch_table_helper.h"
+ (string-append (assoc-ref %outputs "out")
+ "/include/vulkan"))
#t)))
#:configure-flags (list
"-DBUILD_TESTS=OFF" ; FIXME: Needs 'googletest' submodule.
@@ -244,7 +266,7 @@ and the ICD.")
(file-name (git-file-name name version))
(sha256
(base32
- "1mak96jdg3wv043b4jxyv1fm2cz4nnallg0yb90my3yp5q64grrw"))))
+ "0an9hqvvpfmfld2pkszzwi7ccb9g2ijjqqzlj24dqg9kqnmcr3x4"))))
(build-system cmake-build-system)
(inputs
`(("glslang" ,glslang)
diff --git a/gnu/packages/xiph.scm b/gnu/packages/xiph.scm
index 8f900cf90d..804cfd39a7 100644
--- a/gnu/packages/xiph.scm
+++ b/gnu/packages/xiph.scm
@@ -160,14 +160,14 @@ stereo encoding, and voice activity detection.")
(define speexdsp
(package
(name "speexdsp")
- (version "1.2rc3")
+ (version "1.2.0")
(source (origin
(method url-fetch)
(uri (string-append "https://downloads.xiph.org/releases/speex/"
"speexdsp-" version ".tar.gz"))
(sha256
(base32
- "1wcjyrnwlkayb20zdhp48y260rfyzg925qpjpljd5x9r01h8irja"))))
+ "0wa7sqpk3x61zz99m7lwkgr6yv62ml6lfgs5xja65vlvdzy44838"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '(,@(if (string=? "aarch64-linux"
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 7099745ab3..6e503e7b43 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5195,16 +5195,7 @@ draggable titlebars and borders.")
(define-public xorg-server-for-tests
(hidden-package
(package
- (inherit xorg-server)
- (version "1.20.4")
- (source (origin
- (inherit (package-source xorg-server))
- (uri (string-append
- "mirror://xorg/individual/xserver/"
- "xorg-server-" version ".tar.bz2"))
- (sha256
- (base32
- "1vk6j7hmigfill9x8m7a6vvgb3s50ji2yf6yprbgqfz9xf9x83zy")))))))
+ (inherit xorg-server))))
(define-public xorg-server-xwayland
(package