summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/haskell-xyz.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index e368082c03..03adfdb062 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -5679,7 +5679,7 @@ for Haskell. The functions provided by this module are @code{upper},
(define-public ghc-hsyaml
(package
(name "ghc-hsyaml")
- (version "0.1.2.0")
+ (version "0.2.1.0")
(source
(origin
(method url-fetch)
@@ -5687,11 +5687,13 @@ for Haskell. The functions provided by this module are @code{upper},
"HsYAML/HsYAML-" version ".tar.gz"))
(sha256
(base32
- "1pajfhj16559v64ixm8j7bvxdqmxg6c3c0z3wz7in8ckswgzfp54"))))
+ "10qzhsg789h37q22hm9p27dx4rhbykcbxp7p3pvkws8fr7ajgxv0"))))
(build-system haskell-build-system)
- (arguments
- `(#:cabal-revision
- ("1" "0j6qmmcz5yqh89hs2cq453maix50q61vl2h0ahj5lg02bygn42cf")))
+ (inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)))
+ (native-inputs
+ `(("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)))
(home-page "https://github.com/haskell-hvr/HsYAML")
(synopsis "Pure Haskell YAML 1.2 parser")
(description "This library provides a