summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am10
-rw-r--r--build-aux/sync-descriptions.scm (renamed from build-aux/sync-synopses.scm)17
2 files changed, 20 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 22a3b0824d..c2d6b9338f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -156,7 +156,7 @@ EXTRA_DIST = \
build-aux/check-available-binaries.scm \
build-aux/download.scm \
build-aux/list-packages.scm \
- build-aux/sync-synopses.scm \
+ build-aux/sync-descriptions.scm \
srfi/srfi-37.scm.in \
srfi/srfi-64.scm \
srfi/srfi-64.upstream.scm \
@@ -211,12 +211,12 @@ AM_DISTCHECK_CONFIGURE_FLAGS = \
--with-nix-prefix="$(NIX_PREFIX)" \
--enable-daemon
-dist-hook: sync-synopses gen-ChangeLog assert-no-store-file-names
+dist-hook: sync-descriptions gen-ChangeLog assert-no-store-file-names
distcheck-hook: assert-binaries-available
-sync-synopses:
+sync-descriptions:
-$(top_builddir)/pre-inst-env $(GUILE) \
- $(top_srcdir)/build-aux/sync-synopses.scm
+ $(top_srcdir)/build-aux/sync-descriptions.scm
gen-ChangeLog:
if test -d .git; then \
@@ -240,5 +240,5 @@ assert-binaries-available:
$(top_builddir)/pre-inst-env "$(GUILE)" \
"$(top_srcdir)/build-aux/check-available-binaries.scm"
-.PHONY: sync-synopses gen-ChangeLog
+.PHONY: sync-descriptions gen-ChangeLog
.PHONY: assert-no-store-file-names assert-binaries-available
diff --git a/build-aux/sync-synopses.scm b/build-aux/sync-descriptions.scm
index c1049d3398..61362a1f88 100644
--- a/build-aux/sync-synopses.scm
+++ b/build-aux/sync-descriptions.scm
@@ -17,7 +17,8 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
;;;
-;;; Report synopses that defer from those found in the GNU Womb.
+;;; Report package synopses and descriptions that defer from those found in
+;;; the GNU Womb.
;;;
(use-modules (guix gnu-maintenance)
@@ -58,5 +59,17 @@
(format (guix-warning-port)
"~a: ~a: proposed synopsis: ~s~%"
(location->string loc) (package-name package)
- upstream)))))
+ upstream)))
+
+ (let ((upstream (gnu-package-doc-description descriptor))
+ (downstream (package-description package))
+ (loc (or (package-field-location package 'description)
+ (package-location package))))
+ (when (and upstream
+ (not (string=? (fill-paragraph upstream 100)
+ (fill-paragraph downstream 100))))
+ (format (guix-warning-port)
+ "~a: ~a: proposed description:~% ~a~%"
+ (location->string loc) (package-name package)
+ (fill-paragraph upstream 77 7))))))
gnus)