summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index be452f0627..00598776ab 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -359,11 +359,12 @@ data types.")
(package (inherit python-2)
(name "python-minimal")
(outputs '("out"))
- (arguments
- (substitute-keyword-arguments (package-arguments python-2)
- ((#:configure-flags cf)
- `(append ,cf '("--without-system-ffi")))))
- (inputs '()))) ;none of the optional dependencies
+
+ ;; Keep zlib, which is used by 'pip' (via the 'zipimport' module), which
+ ;; is invoked upon 'make install'. 'pip' also expects 'ctypes' and thus
+ ;; libffi.
+ (inputs `(("libffi" ,libffi)
+ ("zlib" ,zlib)))))
(define-public python-minimal
(package (inherit python)