summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crates-io.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 1bbde4342f..cfde654185 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -16287,6 +16287,30 @@ updated when the crate version changes.")
"The uninhabited void type for use in statically impossible cases.")
(license license:expat)))
+(define-public rust-vswhom-sys-0.1
+ (package
+ (name "rust-vswhom-sys")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "vswhom-sys" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0clm4dx4amwlhg5lkh52fmvvwq6c7s7b9xqljw39mryhsc158bzw"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-libc" ,rust-libc-0.2)
+ ("rust-cc" ,rust-cc-1.0))))
+ (home-page "https://github.com/nabijaczleweli/vswhom-sys.rs")
+ (synopsis "Pure FFI to Jon Blow's VS discovery script")
+ (description
+ "This package provides a pure FFI to Jon Blow's VS discovery script.")
+ (license license:expat)))
+
(define-public rust-vte-0.3
(package
(name "rust-vte")