summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/rust.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 448ce893d4..780c2830c6 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -719,6 +719,13 @@ jemalloc = \"" jemalloc "/lib/libjemalloc_pic.a" "\"
(substitute* "config.toml"
(("codegen-tests = false") ""))
#t))
+ ;; FIXME: Re-enable this test if it's indeed supposed to work.
+ ;; See <https://github.com/rust-lang/rust/issues/54178>.
+ (add-after 'enable-codegen-tests 'disable-nil-enum-test
+ (lambda _
+ (substitute* "src/test/debuginfo/nil-enum.rs"
+ (("ignore-lldb") "ignore-gdb"))
+ #t))
(replace 'patch-aarch64-test
(lambda _
(substitute* "src/librustc_metadata/dynamic_lib.rs"