summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crates-io.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a5c9aa4917..d9cc522af6 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -6750,6 +6750,28 @@ implementation of LZMA and xz stream encoding/decoding.")
platform-independently.")
(license license:expat)))
+(define-public rust-malloc-buf-0.0
+ (package
+ (name "rust-malloc-buf")
+ (version "0.0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "malloc-buf" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1jqr77j89pwszv51fmnknzvd53i1nkmcr8rjrvcxhm4dx1zr1fv2"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-libc" ,rust-libc-0.2))))
+ (home-page "https://github.com/SSheldon/malloc_buf")
+ (synopsis "Structs for handling malloc'd memory passed to Rust")
+ (description
+ "This package provides structs for handling malloc'd memory passed to Rust.")
+ (license license:expat)))
+
(define-public rust-maplit-1.0
(package
(name "rust-maplit")