summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bioinformatics.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 6d36bb73ba..5ec600598b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8418,6 +8418,13 @@ library implementing most of the pipeline's features.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-before 'configure 'find-RCAS
+ ;; The configure script can't find non-1.3.x versions of RCAS because
+ ;; its R expression ‘1.10.1 >= 1.3.4’ evaluates to false.
+ (lambda _
+ (substitute* "configure"
+ (("1\\.3\\.4") "0.0.0"))
+ #t))
(add-after 'install 'wrap-executable
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))